Download Page

ESF Database Migration Toolkit is the most popular toolkit to helps people to migrate data across various database formats, including Oracle, SQL Server, MySQL, PostgreSQL, DB2, MS Access, MS Excel, Informix, SQLite, Foxpro/dBase, Firebird, Paradox, Text/CSV and so on. Please reading END-USER LICENSE AGREEMENT.

 Windows    Version: 8.2.09, Released: Dec 12, 2014 .Msi .Zip
ESF Database Migration Toolkit - Standard Edition Msi File Zip File
ESF Database Migration Toolkit - Professional Edition Msi File Zip File
Database/File Systems Standard Professional
Oracle® 9i or above    
MySQL® 3.23 or above    
SQL Server® 6.5 or above    
PostgreSQL® 7.x or above    
IBM® DB2® 7.x or above    
IBM® Informix® 7.x or above    
Teradata®    
InterSystems® Caché®    
Microsoft® Access® 95 or above    
Microsoft® Excel® 95 or above    
Visual Foxpro® (free DBF/DBC)    
SQLite 3.x    
FireBird/Interbase    
Paradox® 3.x/4.x/5.x    
dBase III/IV/5    
Lotus® 1-2-3    
CSV/Text    
Outlook®/Exchange® mailbox    
HTML table import/export    
Form any ODBC DSN    
Feature Matrix Standard Professional
Copy table structure/indexes/foreign keys/data    
Copy auto-increment ID    
Data filter    
Table/field name/datatype/properties mapping    
Preview data    
Save conversion as job    
Load conversion from job    
Run from command line    
Running via Windows Scheduled Tasks    

Let ESF Database Migration Toolkit GUI display your LANGUAGE! >>>>

Suggested Uses:

  • Requires Microsoft Windows 2003/XP or later.
  • How to uninstall?
  • All of installations had included Oracle, MySQL, PostgreSQL, SQLite, FireBird runtime-libarys, so you can migrating from these database formats directly after installed this toolkit.
  • If you want to migrate from/to SQL Server, you need to install SQL Native Client.
  • If you want to migrate from/to IBM DB2, you need to install IBM DB2 ODBC CLI driver.
  • If you want to migrate from/to Visual Foxpro, you need to install OLE DB Provider for Visual FoxPro.
  • If you are using an older version of Windows OS, you may need to install MDAC 2.8 for Access, Excel, Paradox, Lotus, dBase supporting.
  • If you want to migrate from/to Access 2007(*.accdb)/Excel 2007(*.xlsx;*.xlsb), you need to install 2007 Office System Driver.
  • If you want to migrate from/to Access 2010(*.accdb)/Excel 2010(*.xlsx;*.xlsb), you need to install Microsoft Access Database Engine 2010.